Question Encore et toujours du VBS (Resolu)

Plus d'informations
il y a 17 ans 6 jours #523 par Berfini
Alors toujours dans mon intention de convertir du VBS en PS, je me heurte a ce probleme la :

VBS :
Set WshSysEnv = oShell.Environment(\"PROCESS\")
sLogonServer=WshSysEnv(\"LOGONSERVER\")

Convertion PS :
$WshSysEnv = $oShell.Environment(\"PROCESS\")
$sLogonServer=$WshSysEnv(\"LOGONSERVER\")

Le probleme c'est que PS n'accepte pas $WshSysEnv(\"LOGONSERVER\").

Comment dois-je faire pour faire rentrer la valeur de LOGONSERVER contenue dans WshSysEnv dans la variable sLogonServer ?<br><br>Message édité par: Gaby, à: 16/07/07 13:04

Gaby

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 17 ans 6 jours #526 par Robin Lemesle
Réponse de Robin Lemesle sur le sujet Re:Encore et toujours du VBS
Comme pour ton autre problème, regarde si en introduisant l'instruction \&quot;item()\&quot; cela fonctionne !

[code:1]$WshSysEnv = $oShell.Environment(\&quot;PROCESS\&quot;«»)

$sLogonServer=$WshSysEnv.Item(\&quot;LOGONSERVER\&quot;«»)[/code:1]



Rob

Robin MVP PowerShell

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 17 ans 5 jours #529 par Berfini
Réponse de Berfini sur le sujet Re:Encore et toujours du VBS
Econre Merci Robin, comme pour l'autre ça marche niquel !

Gaby

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.100 secondes
Propulsé par Kunena